Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jul 17, 2025 - 10:00 BST
Scheduled
On Thursday the 17th of July we are planning to upgrade the HA mail cluster (mailout.dcmanaged.com), both mailservers which make up the cluster will be removed and replaced with updated systems.
We do not expect any change in functionality for the vast majority of clients, mail will continue to be sent during and after this maintenance in the same way (SMTP to localhost and then smarthosted via mailout.dcmanaged.com).
If however, you have any custom code which interacts with the mail system or handles undeliverable email, please contact us so we can confirm compatibility before this change is made.
Best regards,
The DCL Operations Team
Posted Jul 14, 2025 - 11:38 BST
This scheduled maintenance affected: Platform Applications (Mail Relay).