DynDNS - Intermittent Slow DNS Responses
Incident Report for Digital Craftsmen
Resolved
Our team are no longer seeing issues, normal high speed, low latency DNS responses are being seen from the DynDNS network again.

DCL will continue to monitor this closely, please raise a support ticket if you have any queries.
Posted Aug 06, 2019 - 17:18 BST
Investigating
We are currently seeing some requests to DyNDNS servers responding slower than normal.
Requests using the DCL Slave name servers are working as expected.

We are currently investigating this issue with the Support Team at DynDNS
Posted Aug 06, 2019 - 17:00 BST
This incident affected: Third-Party Applications (CloudNS).