CloudFlare 502 Errors
Incident Report for Digital Craftsmen
Resolved
Cloudflare has resolved the issue and services have resumed normal operation.

A major outage impacted all Cloudflare services globally. A massive spike in CPU caused primary and secondary systems to fall over. The process that was causing the CPU spike were shut down. Services were restored to normal within approximately 20 minutes. Cloudflare are now investigating the root cause of what happened.

A media report on the outage can be found here https://www.bbc.co.uk/news/technology-48841815
Posted Jul 02, 2019 - 16:16 BST
Update
Cloudflare has implemented a fix for this issue and is currently monitoring the results.

We will update the status once the issue is resolved.
Posted Jul 02, 2019 - 15:30 BST
Investigating
Some client websites using the CloudFlare CDN and WAF services may be experiencing 502 Gateway errors.

CloudFlare are aware of this issue and are investigating further, for the latest updates please visit: https://www.cloudflarestatus.com/
Posted Jul 02, 2019 - 14:56 BST