DCL - Support System
Incident Report for Digital Craftsmen
Resolved
Hi,

This issue has been resolved and the support system has been running without issue for the last hour.

regards,

Paul Orrock
Posted May 01, 2024 - 15:52 BST
Investigating
The Request Tracker DCL Support system is currently unavailable - we are investigating this now and will restore services as quickly as possible.

If you need Urgent support for your system please call our support number (020 7183 1555).

Further Updates to follow via this statuspage

--
DCL Support Team
Posted May 01, 2024 - 13:46 BST
This incident affected: Support (Service Desk, Email System).