The datacentre links were re-established at 11:20 and we have monitored stable connections since then. We are working with the supplier to understand the root cause of the dual-failure and to mitigate future incidents.
I am very sorry for the outage and the extended time it took to restore operations.
If you would like further details when they are available, please contact us through your usual support channels.
Simon Wilcox Managing Director
Posted Feb 04, 2026 - 17:35 GMT
Monitoring
Connectivity between the datacentres has been restored on one link and we are monitoring recoveries. Work continues to restore full resilience, and to understand the root cause of connectivity loss.
Posted Feb 04, 2026 - 11:28 GMT
Identified
The network issues are caused by a failure in our upstream network provider. We are working with them to implement a temporary fix.
We will update here when we have more news.
I am very sorry for the interruption and the inconvenience it is causing.
Simon Wilcox.
Posted Feb 04, 2026 - 09:14 GMT
Investigating
Unfortunately both of the intersite links between datacentres have failed which means that services between sites and client applications that rely on this connectivity will be down. We are talking to our provider currently about what the issue is and their resolution. Some of our clients will not be affected due to their sites not requiring this link. If you are affected and want further details please raise a ticket with us.
Posted Feb 04, 2026 - 05:29 GMT
This incident affected: Infrastructure (Core network) and Locations (Enfield Datacentre, Welwyn Garden City Datacentre).