COVID-19 Coronavirus - Operations Update - 12 March 2020
Incident Report for Digital Craftsmen
Resolved
This incident has been resolved.
Posted Jan 15, 2021 - 17:12 GMT
Monitoring
As the WHO (World Health Organisation) has declared Covid-19 a worldwide pandemic, we’d like to take this opportunity to reassure and outline some of the measures in place for our Clients.

In line with our ISO27001 Business Continuity Plan, we have had longstanding plans in place should our staff be unable to attend work at our HQ in London for any reason, as such, all Digital Craftsmen LTD employees have been advised to work from home for the foreseeable future unless their attendance in person is absolutely necessary.

We are well prepared to support our Clients remotely, with secured encrypted access to our and client systems where appropriate and at present there is no degradation of any services. Those clients whose environments are hosted in our datacentres can be assured that in the event of an incident, we have 24/7 support contracts in place for remote-hands within those datacentres to carry out work under our guidance.

We are continually monitoring the Covid-19 situation and following advice and guidelines set out by the UK Government, NHS and the WHO to ensure the safeguarding of our employees and contractual obligations to our Clients.

Please rest assured that we are operating business-as-usual with no change to daily operations and should you need any further information or support during this difficult time, we are here to assist.

We will continue to update you should these circumstances change.
Posted Mar 12, 2020 - 16:16 GMT
This incident affected: Coronavirus COVID-19.